cisco交换机配置命令

发布时间:2017-11-17 11:38:53   来源:文档文库   
字号:

交换机配置

交换机基本的命令:

交换机基本状态:

switch: ROM状态, 路由器是rommon>

hostname> 用户模式

hostname# 特权模式

hostname(config)# 全局配置模式

hostname(config-if)# 接口状态

hostname(config-vlan)# vlan状态

hostname(config-line)# 虚拟终端状态

用户模式

特权模式

全局模式

以上命令为交换机各模式之间的进位转化,当要进行退位时,exit命令退到上一层模式,end命令直接退回特权模式。

交换机口令设置:

switch>enable 进入特权模式

switch#config terminal 进入全局配置模式

switch(config)#hostname xxx 设置交换机的主机名

switch(config)#enable secret xxx 设置特权加密口令

switch(config)#enable password xxx 设置特权非密口令(两个可同时设置,但select优先)

router(config)#service password-encryption (给明文密码加密)

router#show running-config (显示已经完成的配置但可能还没有保存)

router# write (保存当前配置)

//copy running-config startup-config (保存当前配置)

router#show startup-config (显示保存在nvram中的配置文件)

router#show version (显示系统的硬件配置、软件版本、配置文件名称和启动映像信息、寄存器的值

router#show protocol (显示已经配置的三层协议)

router#show interface 接口 (显示相应接口的详细信息)

//配置远程登录交换机进行的设置(否则不能远程登录)

switch(config)#line console 0 进入控制台口

switch(config-line)#line vty 0 4 进入虚拟终端 5个端口

switch(config-line)#login 允许登录(必设)

switch(config-line)#password xx 设置登录口令xx

switch#exit 返回命令

交换机VLAN设置:

switch#vlan database ;进入VLAN设置

switch(vlan)#vlan 2 ;建VLAN 2

switch(vlan)#no vlan 2 ;删vlan 2

switch(config)#int f0/1 ;进入端口1

switch(config-if)#switchport access vlan 2 ;当前端口加入vlan 2

switch(config-if)#switchport mode trunk ;设置为干线

switch(config-if)#switchport trunk allowed vlan 12 ;设置允许的vlan

switch(config-if)#switchport trunk encap dot1q ;设置vlan 中继

switch(config)#vtp domain ;设置发vtp域名

switch(config)#vtp password ;设置发vtp密码

switch(config)#vtp mode server ;设置发vtp模式

switch(config)#vtp mode client ;设置发vtp模式

交换机设置IP地址:

switch(config)#interface vlan 1 ;进入vlan 1

switch(config-if)#ip address ;设置IP地址

switch(config)#ip default-gateway ;设置默认网关

switch#dir flash: ;查看闪存

交换机显示命令:

switch#write ;保存配置信息

switch#show vtp ;查看vtp配置信息

switch#show run ;查看当前配置信息

switch#show vlan ;查看vlan配置信息

switch#show interface ;查看端口信息

switch#show int f0/0 ;查看指定端口信息

路由器支持的命令:



路由器显示命令:

router#show run ;显示配置信息

router#show interface ;显示接口信息

router#show ip route ;显示路由信息

router#show cdp nei ;显示邻居信息

router#reload     ;重新起动

路由器口令设置:

router>enable ;进入特权模式

router#config terminal ;进入全局配置模式

router(config)#hostname ;设置交换机的主机名

router(config)#enable secret xxx ;设置特权加密口令

router(config)#enable password xxb ;设置特权非密口令

router(config)#line console 0 ;进入控制台口

router(config-line)#line vty 0 4 ;进入虚拟终端

router(config-line)#login ;要求口令验证

router(config-line)#password xx ;设置登录口令xx

router(config)#(Ctrl+z) 返回特权模式

router#exit ;返回命令

路由器配置:

router(config)#int s0/0 ;进入Serail接口

router(config-if)#no shutdown ;激活当前接口

router(config-if)#clock rate 64000 ;设置同步时钟

router(config-if)#ip address ;设置IP地址

router(config-if)#ip address second ;设置第二个IP

router(config-if)#int f0/0.1 ;进入子接口

router(config-subif.1)#ip address ;设置子接口IP

router(config-subif.1)#encapsulation dot1q ;绑定vlan中继协议

router(config)#config-register 0x2142 ;跳过配置文件

router(config)#config-register 0x2102 ;正常使用配置文件

router#reload ;重新引导

路由器文件操作:

router#copy running-config startup-config ;保存配置

router#copy running-config tftp ;保存配置到tftp

router#copy startup-config tftp ;开机配置存到tftp

router#copy tftp flash: ;下传文件到flash

router#copy tftp startup-config;下载配置文件

ROM状态:

Ctrl+Break ;进入ROM监控状态

rommon>confreg 0x2142 ;跳过配置文件

rommon>confreg 0x2102 ;恢复配置文件

rommon>reset  ;重新引导

rommon>copy xmodem: flash: ;从console传输文件

rommon>IP_ADDRESS=10.65.1.2 ;设置路由器IP

rommon>IP_SUBNET_MASK=255.255.0.0 ;设置路由器掩码

rommon>TFTP_SERVER=10.65.1.1 ;指定TFTP服务器IP

rommon>TFTP_FILE=c2600.bin ;指定下载的文件

rommon>tftpdnld ;从tftp下载

rommon>dir flash: ;查看闪存内容

rommon>boot ;引导IOS

静态路由:

ip route ;命令格式

router(config)#ip route 2.0.0.0 255.0.0.0 1.1.1.2 ;静态路由举例

router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2 ;默认路由

动态路由:

router(config)#ip routing ;启动路由转发

router(config)#router rip ;启动RIP路由协议。

router(config-router)#network ;设置发布路由

router(config-router)#negihbor ;点对点帧中继用。

帧中继命令:

router(config)#frame-relay switching ;使能帧中继交换

router(config-s0)#encapsulation frame-relay ;使能帧中继

router(config-s0)#fram-relay lmi-type cisco ;设置管理类型

router(config-s0)#frame-relay intf-type DCE ;设置为DCE

router(config-s0)#frame-relay dlci 16

router(config-s0)#frame-relay local-dlci 20 ;设置虚电路号

router(config-s0)#frame-relay interface-dlci 16

router(config)#log-adjacency-changes ;记录邻接变化

router(config)#int s0/0.1 point-to-point ;设置子接口点对点

router#show frame pvc ;显示永久虚电路

router#show frame map ;显示映射

基本访问控制列表:

router(config)#access-list permit|deny

router(config)#interface default:deny any

router(config-if)#ip access-group in|out default:out

1

router(config)#access-list 4 permit 10.8.1.1

router(config)#access-list 4 deny 10.8.1.0 0.0.0.255

router(config)#access-list 4 permit 10.8.0.0 0.0.255.255

router(config)#access-list 4 deny 10.0.0.0 0.255.255.255

router(config)#access-list 4 permit any



router(config)#int f0/0

router(config-if)#ip access-group 4 in

扩展访问控制列表:

access-list permit|deny icmp

wild>[type]

access-list permit|deny tcp

wild>[port]



3



router(config)#access-list 101 deny icmp any 10.64.0.2 0.0.0.0 echo



router(config)#access-list 101 permit ip any any

router(config)#int s0/0

router(config-if)#ip access-group 101 in



3



router(config)#access-list 102 deny tcp any 10.65.0.2 0.0.0.0 eq 80



router(config)#access-list 102 permit ip any any

router(config)#interface s0/1

router(config-if)#ip access-group 102 out

删除访问控制例表:

router(config)#no access-list 102

router(config-if)#no ip access-group 101 in

路由器的nat配置

Router(config-if)#ip nat inside ;当前接口指定为内部接口



Router(config-if)#ip nat outside ;当前接口指定为外部接口



Router(config)#ip nat inside source static [p] <私有IP><公网IP> [port]



Router(config)#ip nat inside source static 10.65.1.2 60.1.1.1



Router(config)#ip nat inside source static tcp 10.65.1.3 80 60.1.1.1 80



Router(config)#ip nat pool p1 60.1.1.1 60.1.1.20 255.255.255.0



Router(config)#ip nat inside source list 1 pool p1



Router(config)#ip nat inside destination list 2 pool p2



Router(config)#ip nat inside source list 2 interface s0/0 overload



Router(config)#ip nat pool p2 10.65.1.2 10.65.1.4 255.255.255.0 type rotary



Router#show ip nat translation



rotary 参数是轮流的意思,地址池中的IP轮流与NAT分配的地址匹配。



overload参数用于PAT 将内部IP映射到一个公网IP不同的端口上。

外部网关协议配置:

routerA(config)#router bgp 100

routerA(config-router)#network 19.0.0.0

routerA(config-router)#neighbor 8.1.1.2 remote-as 200

配置PPP验证:

RouterA(config)#username password

RouterA(config)#int s0

RouterA(config-if)#ppp authentication {chap|pap}

3PIX防火墙命令

Pix525(config)#nameif ethernet0 outside security0 ;命名接口和级别



Pix525(config)#interface ethernet0 auto ;设置接口方式



Pix525(config)#interface ethernet1 100full ;设置接口方式



Pix525(config)#interface ethernet1 100full shutdown



Pix525(config)#ip address inside 192.168.0.1 255.255.255.0



Pix525(config)#ip address outside 133.0.0.1 255.255.255.252

Pix525(config)#global (if_name) natid ip-ip ;定义公网IP区间



Pix525(config)#global (outside) 1 7.0.0.1-7.0.0.15 ;例句



Pix525(config)#global (outside) 1 133.0.0.1 ;例句



Pix525(config)#no global (outside) 1 133.0.0.1 ;去掉设置

Pix525(config)#nat (if_name) nat_id local_ip [netmark]



Pix525(config)#nat (inside) 1 0 0



内网所有主机(0代表0.0.0.0)可以访问global 1指定的外网。



Pix525(config)#nat (inside) 1 172.16.5.0 255.255.0.0



内网172.16.5.0/16网段的主机可以访问global 1指定的外网。

Pix525(config)#route if_name 0 0 gateway_ip [metric] ;命令格式



Pix525(config)#route outside 0 0 133.0.0.1 1 ;例句



Pix525(config)#route inside 10.1.0.0 255.255.0.0 10.8.0.1 1 ;例句

Pix525(config)#static (inside outside) 133.0.0.1 192.168.0.8



表示内部ip地址192.168.0.8,访问外部时被翻译成133.0.0.1全局地址。

Pix525(config)#static (dmz outside) 133.0.0.1 172.16.0.8



中间区域ip地址172.16.0.8,访问外部时被翻译成133.0.0.1全局地址。

Cisco交换机命令清单

2006.3.5

设置主机名:

switch(config)# hostname hostname

设置登录口令

switch(config)# enable password/secret password

配置交换机IP地址

1900(config)#ip address {ip_address} {mask}

2950(config)#interface vlan num

2950(config-if)#ip address {ip_address} {mask}

配置交换机缺省网关

1900(config)# ip default-gateway {ip address}

2950(config)# ip default-gateway {ip address}

设置端口速度:

switch(config-if)# speed {10|100|auto}

端口描述

switch(config-if)# description description-string

显示交换机IP地址

1900#show ip

2950#show interface vlan n

设置以太网的链路模式

1900(config)#interface type-module/port

1900(config-if)#duplex {auto|full|full-flow-control|half}

2950(config)#interface type-module/port

2950(config-if)#duplex {auto | full | half}

设置永久MAC地址

1900 (config)#mac-address-table permanent

{mac-address type module/port}

2950(config)#mac-address-table static mac_addr

{vlan vlan_id} [interface int1 [int2 ... int15]]

Catalyst1900设置受限的静态MAC地址

1900(config)#mac-address-table restricted static

{mac-address type module/port src-if-list}

Catalyst 2950设置受限的静态MAC地址

2950(config)#mac-address-table secure mac-addr interface [vlan vlan-id]

管理MAC地址表

switch #show mac-address-table

switch #clear mac-address-table

配置端口安全性

1900(config-if)# port secure

1900(config-if)# port secure max-mac-count count

1900(config-if)# port security violation protect/restrict/shutdown

1900(config-if)# port security mac-address mac-address

2950 (config-if)# switchport mode access

2950 (config-if)# switchport port-security

2950 (config-if)# switchport port-security [max-mac-count count]

定义该端口在MAC地址表中对应MAC地址的最多条数, 可以定义1 132, 缺省为132

查看Catalyst 1900/2950端口安全性

1900#show mac-address-table security

2950#show mac-address-table secure

清除NVRAM

1900#delete nvram

2950#erase nvram

删除flash中全部vlan信息

switch#delete flash: vlan.dat

创建VTP

1900(config)#vtp [server | transparent | client] [domain domain-name]

[trap {enable | disable}] [password password] [pruning {enable | disable}]

2950#vlan database

2950(vlan)#vtp [ server | client | transparent ]

2950(vlan)#vtp domain domain-name

2950(vlan)#vtp password password

2950(vlan)#vtp pruning<默认启用enable>

2950(vlan)#snmp-server enable traps vtp

2950(vlan)#exit

确认Catalyst 2950/1900VTP配置

1900#show vtp

2950#show vtp status

确认生成树

1900#show spantree [vlan#]

2950#show spanning-tree vlan [vlan#]

关掉生成树协议

1900(config)#no spantree number :每个VLAN都有自己独立的生成树.

创建并将端口加入一个VLAN

1900(config)# vlan vlan# [name vlan-name]

1900(config)#interface type-module/port

1900(config-if)#vlan-membership {static {vlan#} | dynamic}

2950# vlan database

2950 (vlan)# vlan vlan-num name name

2950 (vlan)# exit

2950# configure teriminal

2950 (config)# interface type module/number

2950 (config-if)# switchport mode access

2950 (config-if)# switchport access vlan vlan-num

2950 (config-if)# end

确认一个VLAN

1900#show vlan [vlan#]

2950#show vlan [vlan id #]

修改一个VLAN的名称

switch(config)#vlan vlan# name vlan-name

查看VLAN中的成员

1900#show vlan-membership

2950#show vlan brief

2950#show interfaces interface switchport

删除vlan

1900(config)#no vlan vlan-id

2950(vlan)# no vlan vlan-id

当删除一个VLAN时,原来属于此VLAN的端口将处于非激活的状态,直到将其分配给某一VLAN。所以建议先删除vlan下的端口再删除vlan.

相同类别端口组配置

所有在同一组的端口必须是相同类别的。interface range 命令只能配置已经存在的interface vlan

Switch# configure terminal

Switch(config)# interface range type-mode/port

Switch(config-if-range)# no shutdown

将端口12—15加入到VLAN 3

switch(config)#interface range fa0/12 —15

switch(config-if-range)#switchport mode access

switch(config-if-range)#switchport access VLAN 3

使用逗号来配置不同类型端口的组:

Switch# configure terminal

Switch(config)# interface range fa0/1 - 3, gig0/1 - 2

Switch(config-if-range)# no shutdown

设置端口汇聚

将端口26—27配置成干道端口,并且绑定为一个以太网通道。

1900 (config)#interface port—channel 1 1—6 (创建通道)

1900 (config-if)#interface range fa0/26 —27 (加入端口)

1900 (config-if-range)#channel—range 1 mode on (应用通道)

查看通道

switch#show interface port—channel number1—6

对交换机设置域名.

Switch(config)#ip domain-name domain_name

指向名称服务器

Switch(config)#ip name-server dns-server-ip-address

Switch#show ip name server (查看名称服务器)

设置老化时间,也就相当于租期

Switch(config)#Mac-address-table aging-time

FLASH文件重命扩展名

Switch(config)#rename flash:config.old flash:config.text

查看VTP中继流量

Switch#show vtp counters(计数器)

排除VLAN2通过此中继

Switch(config)#no trunk-vlan 2

switch(config-if)# switchport trunk allowed vlan remove vlan-list

查看端口状态

Switch#show interface fa0/24(trunk) switchprot

设置vlan中继链路

switch(config)# interface interface mod/port

switch(config-if)# switchport mode trunk

switch(config-if)# switchport trunk allowed vlan remove vlan-list

switch(config-if)# switchport trunk allowed vlan add vlan-list

2621route)用中继链路来建立与VLAN的连接:

route (config)# interface module/port.subinterface

route (config-sub)# encapsulation[isl|dotlq] vlan-number

route (config-sub)# ip address ip-address subnet-mask

本文来源:https://www.2haoxitong.net/k/doc/d9a3a962e3bd960590c69ec3d5bbfd0a7956d5ce.html

《cisco交换机配置命令.doc》
将本文的Word文档下载到电脑,方便收藏和打印
推荐度:
点击下载文档

文档为doc格式